Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(833)

Side by Side Diff: cc/surfaces/surface_id_allocator.cc

Issue 2708153005: Rename SurfaceIdAllocator to LocalSurfaceIdAllocator (Closed)
Patch Set: Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 // Copyright 2014 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 #include "cc/surfaces/surface_id_allocator.h"
6
7 #include <stdint.h>
8
9 #include "base/rand_util.h"
10 #include "base/unguessable_token.h"
11
12 namespace cc {
13
14 SurfaceIdAllocator::SurfaceIdAllocator() : next_id_(1u) {}
15
16 SurfaceIdAllocator::~SurfaceIdAllocator() {
17 }
18
19 LocalSurfaceId SurfaceIdAllocator::GenerateId() {
20 LocalSurfaceId id(next_id_, base::UnguessableToken::Create());
21 next_id_++;
22 return id;
23 }
24
25 } // namespace cc
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698