Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(348)

Unified Diff: third_party/WebKit/Source/core/frame/FrameOwner.h

Issue 2697713003: Initial Implementation of Iframe Attribute for Feature Policy (Part 2) (Closed)
Patch Set: Initial Impl Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/frame/FrameOwner.h
diff --git a/third_party/WebKit/Source/core/frame/FrameOwner.h b/third_party/WebKit/Source/core/frame/FrameOwner.h
index 6a2a91401b5b39045c7bc04ffdacf2f0d4258622..e4ac63b1c64a9e7368458bfb6f2743504a682c67 100644
--- a/third_party/WebKit/Source/core/frame/FrameOwner.h
+++ b/third_party/WebKit/Source/core/frame/FrameOwner.h
@@ -9,6 +9,7 @@
#include "core/dom/SandboxFlags.h"
#include "platform/heap/Handle.h"
#include "platform/scroll/ScrollTypes.h"
+#include "public/platform/WebFeaturePolicy.h"
#include "public/platform/WebVector.h"
#include "public/platform/modules/permissions/permission.mojom-blink.h"
@@ -51,6 +52,8 @@ class CORE_EXPORT FrameOwner : public GarbageCollectedMixin {
virtual AtomicString csp() const = 0;
virtual const WebVector<mojom::blink::PermissionName>& delegatedPermissions()
const = 0;
+ virtual const WebVector<WebFeaturePolicyFeature>& allowedFeatureNames()
iclelland 2017/02/16 15:26:33 I feel like we should rename this to allowedFeatur
lunalu1 2017/02/16 20:16:15 Done.
+ const = 0;
iclelland 2017/02/16 15:26:33 I'm curious why this is a pure virtual method, whe
lunalu1 2017/02/16 20:16:15 We can use a default definition here, that just me
iclelland 2017/02/16 20:33:40 I'm just wondering whether the pattern is there fo
iclelland 2017/02/16 20:49:27 I suppose this might be for memory savings -- if t
lunalu1 2017/02/16 21:33:46 According to Google Style Guide (https://google.gi
};
// TODO(dcheng): This class is an internal implementation detail of provisional
@@ -89,6 +92,11 @@ class CORE_EXPORT DummyFrameOwner
());
return permissions;
}
+ const WebVector<WebFeaturePolicyFeature>& allowedFeatureNames()
+ const override {
+ DEFINE_STATIC_LOCAL(WebVector<WebFeaturePolicyFeature>, features, ());
+ return features;
+ }
private:
// Intentionally private to prevent redundant checks when the type is

Powered by Google App Engine
This is Rietveld 408576698