Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(4)

Unified Diff: media/remoting/fake_media_resource.cc

Issue 2668393002: Rename DemuxerStreamProvider into MediaResource (Closed)
Patch Set: rebase Created 3 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: media/remoting/fake_media_resource.cc
diff --git a/media/remoting/fake_demuxer_stream_provider.cc b/media/remoting/fake_media_resource.cc
similarity index 92%
rename from media/remoting/fake_demuxer_stream_provider.cc
rename to media/remoting/fake_media_resource.cc
index 1064e93dc4fb60b6e4624095cea288102fac349f..16d7403559050cb51cb3d5b2ca8cad453035a19c 100644
--- a/media/remoting/fake_demuxer_stream_provider.cc
+++ b/media/remoting/fake_media_resource.cc
@@ -2,7 +2,7 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-#include "media/remoting/fake_demuxer_stream_provider.h"
+#include "media/remoting/fake_media_resource.h"
#include <vector>
@@ -101,12 +101,12 @@ void FakeDemuxerStream::CreateFakeFrame(size_t size,
}
}
-FakeDemuxerStreamProvider::FakeDemuxerStreamProvider()
+FakeMediaResource::FakeMediaResource()
: demuxer_stream_(new FakeDemuxerStream(true)) {}
-FakeDemuxerStreamProvider::~FakeDemuxerStreamProvider() {}
+FakeMediaResource::~FakeMediaResource() {}
-DemuxerStream* FakeDemuxerStreamProvider::GetStream(DemuxerStream::Type type) {
+DemuxerStream* FakeMediaResource::GetStream(DemuxerStream::Type type) {
if (type == DemuxerStream::AUDIO)
return reinterpret_cast<DemuxerStream*>(demuxer_stream_.get());
return nullptr;

Powered by Google App Engine
This is Rietveld 408576698