Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(6)

Side by Side Diff: third_party/WebKit/Source/modules/payments/PaymentRequestEvent.idl

Issue 2665583002: PaymentApp: Rename PaymentAppRequestData to PaymentAppRequest. (Closed)
Patch Set: android Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
1 // Copyright 2016 The Chromium Authors. All rights reserved. 1 // Copyright 2016 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be 2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file. 3 // found in the LICENSE file.
4 4
5 // https://w3c.github.io/webpayments-payment-apps-api/#idl-def-paymentrequesteve nt 5 // https://w3c.github.io/webpayments-payment-apps-api/#idl-def-paymentrequesteve nt
please use gerrit instead 2017/01/30 15:03:32 Please put this URL in the CL description as well.
zino 2017/01/31 09:16:07 Done.
6 6
7 [ 7 [
8 RuntimeEnabled=PaymentApp, 8 RuntimeEnabled=PaymentApp,
9 Exposed=ServiceWorker 9 Exposed=ServiceWorker
10 ] interface PaymentRequestEvent : ExtendableEvent { 10 ] interface PaymentRequestEvent : ExtendableEvent {
11 readonly attribute PaymentAppRequestData data; 11 readonly attribute PaymentAppRequest appRequest;
12 void respondWith(Promise<PaymentResponse> response); 12 void respondWith(Promise<PaymentResponse> response);
13 }; 13 };
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698