Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(807)

Unified Diff: content/common/navigation_params.h

Issue 2655463006: PlzNavigate: Enforce 'frame-src' CSP on the browser. (Closed)
Patch Set: Add TODO in the FrameLoader. Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: content/common/navigation_params.h
diff --git a/content/common/navigation_params.h b/content/common/navigation_params.h
index c47da6b89c797ca8ceb40b93f578effdf10bbe92..ade049004106ca661de03aa1e2b7a3940414e3e7 100644
--- a/content/common/navigation_params.h
+++ b/content/common/navigation_params.h
@@ -58,7 +58,8 @@ struct CONTENT_EXPORT CommonNavigationParams {
PreviewsState previews_state,
const base::TimeTicks& navigation_start,
std::string method,
- const scoped_refptr<ResourceRequestBodyImpl>& post_data);
+ const scoped_refptr<ResourceRequestBodyImpl>& post_data,
+ bool should_bypass_main_world_csp);
CommonNavigationParams(const CommonNavigationParams& other);
~CommonNavigationParams();
@@ -119,6 +120,12 @@ struct CONTENT_EXPORT CommonNavigationParams {
// Body of HTTP POST request.
scoped_refptr<ResourceRequestBodyImpl> post_data;
+
+ // Returns true if the navigation was initiated from an isolated world. An
+ // isolated world has its own Content Security Policy. In this case, the
+ // policy of the main world should be ignored when evaluating resources
+ // injected into the DOM.
+ bool should_bypass_main_world_csp;
nasko 2017/02/15 21:28:44 nit: Shouldn't we name the variable based on what
arthursonzogni 2017/02/16 17:32:41 I agree. Edit: I don't know, I am using the same
};
// Provided by the renderer ----------------------------------------------------

Powered by Google App Engine
This is Rietveld 408576698