Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(136)

Unified Diff: runtime/vm/raw_object.h

Issue 2654183002: Rename references to "external pages" as "snapshot pages" to avoid confusion with the kind of exter… (Closed)
Patch Set: image Created 3 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: runtime/vm/raw_object.h
diff --git a/runtime/vm/raw_object.h b/runtime/vm/raw_object.h
index a3edb3011362319997fa5ae110243bdd2083a608..b6945186ce43b5f176b91e1ca3aaefd9028ef927 100644
--- a/runtime/vm/raw_object.h
+++ b/runtime/vm/raw_object.h
@@ -609,9 +609,9 @@ class RawObject {
friend class RetainingPathVisitor; // GetClassId
friend class SkippedCodeFunctions; // StorePointer
friend class InstructionsReader; // tags_ check
- friend class InstructionsWriter;
- friend class AssemblyInstructionsWriter;
- friend class BlobInstructionsWriter;
+ friend class ImageWriter;
+ friend class AssemblyImageWriter;
+ friend class BlobImageWriter;
friend class SnapshotReader;
friend class Deserializer;
friend class SnapshotWriter;
@@ -1214,7 +1214,7 @@ class RawInstructions : public RawObject {
friend class SkippedCodeFunctions;
friend class Function;
friend class InstructionsReader;
- friend class InstructionsWriter;
+ friend class ImageWriter;
};
« runtime/vm/isolate.cc ('K') | « runtime/vm/pages.cc ('k') | runtime/vm/snapshot.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698