Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(291)

Unified Diff: content/common/service_worker/service_worker_provider.mojom

Issue 2653493009: Add two interfaces for ServiceWorkerProviderContext/ProviderHost (Closed)
Patch Set: Rebased/Fixed unittests when BrowserSideNavigation is enabled Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: content/common/service_worker/service_worker_provider.mojom
diff --git a/content/common/service_worker/service_worker_provider.mojom b/content/common/service_worker/service_worker_provider.mojom
index 6e512eddca89cde7db77394ec9104b309c70da5b..6240d84e83fa3a6cfac27ef181349201fd14bdc2 100644
--- a/content/common/service_worker/service_worker_provider.mojom
+++ b/content/common/service_worker/service_worker_provider.mojom
@@ -4,6 +4,7 @@
module content.mojom;
+import "content/common/service_worker/service_worker_provider_interfaces.mojom";
import "content/common/service_worker/service_worker_types.mojom";
// A container object carried from the renderer to the browser process.
@@ -15,4 +16,6 @@ struct ServiceWorkerProviderHostInfo {
int32 route_id;
ServiceWorkerProviderType type;
bool is_parent_frame_secure;
+ associated ServiceWorkerProviderHost& host_request;
+ associated ServiceWorkerProvider client_ptr_info;
falken 2017/05/18 04:13:10 Does it make more sense to just name these |provid
shimazu 2017/05/19 08:31:07 I thought _request/_ptr_info are informative becau
falken 2017/05/22 08:28:12 OK if this is consistent with a common Mojo naming
};

Powered by Google App Engine
This is Rietveld 408576698