Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(836)

Unified Diff: pkg/compiler/lib/src/js_emitter/full_emitter/emitter.dart

Issue 2625713002: Rename Enqueuer.universe to worldBuilder. (Closed)
Patch Set: Updated cf. comments Created 3 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/compiler/lib/src/js_emitter/full_emitter/emitter.dart
diff --git a/pkg/compiler/lib/src/js_emitter/full_emitter/emitter.dart b/pkg/compiler/lib/src/js_emitter/full_emitter/emitter.dart
index 3d8ea6ccb2fd595e44aedfbe34723a34a92d08cb..c22eb0b190f7e4f876326f81060e6dc9b91aed7b 100644
--- a/pkg/compiler/lib/src/js_emitter/full_emitter/emitter.dart
+++ b/pkg/compiler/lib/src/js_emitter/full_emitter/emitter.dart
@@ -1891,7 +1891,8 @@ function(originalDescriptor, name, holder, isStatic, globalFunctionsAccess) {
// specific to the class. For now, not supported for native classes and
// native elements.
ClassElement cls = element.enclosingClassOrCompilationUnit.declaration;
- if (compiler.codegenWorld.directlyInstantiatedClasses.contains(cls) &&
+ if (compiler.codegenWorldBuilder.directlyInstantiatedClasses
+ .contains(cls) &&
!backend.isNative(cls) &&
compiler.deferredLoadTask.outputUnitForElement(element) ==
compiler.deferredLoadTask.outputUnitForElement(cls)) {

Powered by Google App Engine
This is Rietveld 408576698