Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2069)

Unified Diff: tests/lib/async/catch_errors27_test.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Fix 80 chars lines Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: tests/lib/async/catch_errors27_test.dart
diff --git a/tests/lib/async/catch_errors27_test.dart b/tests/lib/async/catch_errors27_test.dart
index 9a1f0d7dda8f668494763de48a2244d222d4ae0f..06f819b060d67b54459515df51e139907f0e1ce4 100644
--- a/tests/lib/async/catch_errors27_test.dart
+++ b/tests/lib/async/catch_errors27_test.dart
@@ -31,7 +31,7 @@ main() {
.transform(new StreamTransformer.fromHandlers(
handleError: (e, st, sink) => sink.add("error $e")))
.listen((x) { events.add("stream $x"); });
- runAsync(() {
+ scheduleMicrotask(() {
controller.add(1);
// Errors are not allowed to traverse boundaries, but in this case the
// first listener of the broadcast stream is in the same error-zone. So

Powered by Google App Engine
This is Rietveld 408576698