Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(229)

Unified Diff: pkg/observe/lib/src/observable_list.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Fix 80 chars lines Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/observe/lib/src/observable_list.dart
diff --git a/pkg/observe/lib/src/observable_list.dart b/pkg/observe/lib/src/observable_list.dart
index 63ec81c90c40a967ff14019f229b7e88e2cc0cd2..e9a2822c1e5d31ee7fcdf0a15213e2284b8b153e 100644
--- a/pkg/observe/lib/src/observable_list.dart
+++ b/pkg/observe/lib/src/observable_list.dart
@@ -181,7 +181,7 @@ class ObservableList<E> extends ListBase<E> with ChangeNotifierMixin {
void _recordChange(ListChangeRecord record) {
if (_listRecords == null) {
_listRecords = [];
- runAsync(deliverChanges);
+ scheduleMicrotask(deliverChanges);
}
_listRecords.add(record);
}

Powered by Google App Engine
This is Rietveld 408576698