Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(87)

Unified Diff: third_party/pkg/js/lib/js.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Add test. Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/pkg/js/lib/js.dart
diff --git a/third_party/pkg/js/lib/js.dart b/third_party/pkg/js/lib/js.dart
index 8adb099f42f82adcc5d724b2fb45365a047e2258..d1eb7acd4982ea26edad1cf20e7d2f771ec6cee0 100644
--- a/third_party/pkg/js/lib/js.dart
+++ b/third_party/pkg/js/lib/js.dart
@@ -733,7 +733,7 @@ get _depth => _proxiedObjectTable._scopeIndices.length;
void _enterScopeIfNeeded() {
if (_depth == 0) {
var depth = _enterScope();
- runAsync(() => _exitScope(depth));
+ scheduleMicrotask(() => _exitScope(depth));
}
}
« no previous file with comments | « tests/standalone/io/http_server_early_client_close_test.dart ('k') | third_party/pkg/js/test/js/browser_tests.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698