Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(367)

Unified Diff: tests/lib/async/catch_errors3_test.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Add test. Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « tests/lib/async/catch_errors27_test.dart ('k') | tests/lib/async/future_microtask_test.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: tests/lib/async/catch_errors3_test.dart
diff --git a/tests/lib/async/catch_errors3_test.dart b/tests/lib/async/catch_errors3_test.dart
index 10b5f1b03d8494ab270727097d19cf197ee6d3e0..e4690f2becd92e17a7110a164ff8f83ceb2f7aaf 100644
--- a/tests/lib/async/catch_errors3_test.dart
+++ b/tests/lib/async/catch_errors3_test.dart
@@ -18,7 +18,7 @@ main() {
new Future(() => 499).then((x) {
futureWasExecuted = true;
});
- runAsync(() {
+ scheduleMicrotask(() {
new Future(() => 42).then((x) {
future2WasExecuted = true;
Expect.isTrue(futureWasExecuted);
« no previous file with comments | « tests/lib/async/catch_errors27_test.dart ('k') | tests/lib/async/future_microtask_test.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698