Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(623)

Unified Diff: pkg/unittest/lib/unittest.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Add test. Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/unittest/lib/unittest.dart
diff --git a/pkg/unittest/lib/unittest.dart b/pkg/unittest/lib/unittest.dart
index 40408708603458500d7125b5ccabfed1ac083045..9eac4647ec9834a31401ad21a6d2f6f26df9d8ed 100644
--- a/pkg/unittest/lib/unittest.dart
+++ b/pkg/unittest/lib/unittest.dart
@@ -763,7 +763,7 @@ void _runTest() {
_lastBreath = now;
Timer.run(_nextTestCase);
} else {
- runAsync(_nextTestCase); // Schedule the next test.
+ scheduleMicrotask(_nextTestCase); // Schedule the next test.
}
});
}
@@ -817,7 +817,7 @@ void _ensureInitialized(bool configAutoStart) {
if (configAutoStart && _config.autoStart) {
// Immediately queue the suite up. It will run after a timeout (i.e. after
// main() has returned).
- runAsync(runTests);
+ scheduleMicrotask(runTests);
}
}
« no previous file with comments | « pkg/scheduled_test/lib/src/utils.dart ('k') | pkg/unittest/test/unittest_test_returning_future_using_runasync_test.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698