Chromium Code Reviews

Unified Diff: pkg/observe/lib/src/list_path_observer.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Add test. Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments.
Jump to:
View side-by-side diff with in-line comments
« no previous file with comments | « pkg/observe/lib/src/compound_binding.dart ('k') | pkg/observe/lib/src/microtask.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: pkg/observe/lib/src/list_path_observer.dart
diff --git a/pkg/observe/lib/src/list_path_observer.dart b/pkg/observe/lib/src/list_path_observer.dart
index 5b83a25b58cf99494a59be4ea81664cbc5c62731..a754ac6c6128b0338592111a57dd9417cafd9293 100644
--- a/pkg/observe/lib/src/list_path_observer.dart
+++ b/pkg/observe/lib/src/list_path_observer.dart
@@ -55,7 +55,7 @@ class ListPathObserver<E, P> extends ChangeNotifierBase {
void _scheduleReduce(_) {
if (_scheduled) return;
_scheduled = true;
- runAsync(_reduce);
+ scheduleMicrotask(_reduce);
}
void _observeItems(int lengthAdjust) {
« no previous file with comments | « pkg/observe/lib/src/compound_binding.dart ('k') | pkg/observe/lib/src/microtask.dart » ('j') | no next file with comments »

Powered by Google App Engine