Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2172)

Unified Diff: pkg/observe/lib/src/change_notifier.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Add test. Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « pkg/mdv/test/template_element_test.dart ('k') | pkg/observe/lib/src/compound_binding.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: pkg/observe/lib/src/change_notifier.dart
diff --git a/pkg/observe/lib/src/change_notifier.dart b/pkg/observe/lib/src/change_notifier.dart
index 8102ab0c7110b3ca5f2f4bdafb197e7360e32c0d..6dc132ee952f64557da8e97cfc0dd8bbe8fa40e9 100644
--- a/pkg/observe/lib/src/change_notifier.dart
+++ b/pkg/observe/lib/src/change_notifier.dart
@@ -85,7 +85,7 @@ abstract class ChangeNotifierMixin implements Observable {
if (_records == null) {
_records = [];
- runAsync(deliverChanges);
+ scheduleMicrotask(deliverChanges);
}
_records.add(record);
}
« no previous file with comments | « pkg/mdv/test/template_element_test.dart ('k') | pkg/observe/lib/src/compound_binding.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698