Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(376)

Unified Diff: pkg/custom_element/lib/custom_element.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Add test. Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « pkg/barback/lib/src/utils.dart ('k') | pkg/mdv/lib/src/input_bindings.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: pkg/custom_element/lib/custom_element.dart
diff --git a/pkg/custom_element/lib/custom_element.dart b/pkg/custom_element/lib/custom_element.dart
index a91ff698d64768ea42f4d31ce471fc8e39e98409..5ea5ca0915cc6fc560da95216e0989eba0eb1a57 100644
--- a/pkg/custom_element/lib/custom_element.dart
+++ b/pkg/custom_element/lib/custom_element.dart
@@ -625,7 +625,7 @@ void _initCustomElement(Element node, CustomElement ctor()) {
}
void _registerLifecycleInsert(CustomElement element) {
- runAsync(() {
+ scheduleMicrotask(() {
// TODO(jmesserly): bottom up or top down insert?
var node = element.host;
« no previous file with comments | « pkg/barback/lib/src/utils.dart ('k') | pkg/mdv/lib/src/input_bindings.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698