Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(29)

Side by Side Diff: tests/lib/async/intercept_run_async1_test.dart

Issue 26151002: Rename runAsync to scheduleMicrotask. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Add test. Created 7 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch | Annotate | Revision Log
OLDNEW
1 // Copyright (c) 2013, the Dart project authors. Please see the AUTHORS file 1 // Copyright (c) 2013, the Dart project authors. Please see the AUTHORS file
2 // for details. All rights reserved. Use of this source code is governed by a 2 // for details. All rights reserved. Use of this source code is governed by a
3 // BSD-style license that can be found in the LICENSE file. 3 // BSD-style license that can be found in the LICENSE file.
4 4
5 import "package:expect/expect.dart"; 5 import "package:expect/expect.dart";
6 import 'dart:async'; 6 import 'dart:async';
7 7
8 main() { 8 main() {
9 // Test that runZoned returns the result of executing the body. 9 // Test that runZoned returns the result of executing the body.
10 var result = runZonedExperimental(() => 499, 10 var result = runZonedExperimental(() => 499,
11 onRunAsync: (f) { 11 onScheduleMicrotask: (f) {
12 Expect.fail("Unexpected invocation."); 12 Expect.fail("Unexpected invocation.");
13 }); 13 });
14 Expect.equals(499, result); 14 Expect.equals(499, result);
15 } 15 }
OLDNEW
« no previous file with comments | « tests/lib/async/future_value_chain4_test.dart ('k') | tests/lib/async/intercept_run_async2_test.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698