Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(667)

Side by Side Diff: media/base/media_keys.cc

Issue 2568463003: media: Rename MediaKeys to ContentDecryptionModule (Closed)
Patch Set: Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 // Copyright 2013 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 #include "media/base/media_keys.h"
6
7 namespace media {
8
9 MediaKeys::MediaKeys() {}
10
11 MediaKeys::~MediaKeys() {}
12
13 CdmContext* MediaKeys::GetCdmContext() {
14 return nullptr;
15 }
16
17 void MediaKeys::DeleteOnCorrectThread() const {
18 delete this;
19 }
20
21 // static
22 void MediaKeysTraits::Destruct(const MediaKeys* media_keys) {
23 media_keys->DeleteOnCorrectThread();
24 }
25
26 } // namespace media
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698