Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1717)

Unified Diff: components/history/core/browser/typed_url_data_type_controller.cc

Issue 2549223003: [Sync] Rename NonUIDataTypeController to AsyncDirectoryTypeController (Closed)
Patch Set: Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/history/core/browser/typed_url_data_type_controller.cc
diff --git a/components/history/core/browser/typed_url_data_type_controller.cc b/components/history/core/browser/typed_url_data_type_controller.cc
index 69424586ed9e339359ecfac7cdabd430df218a16..d27a4f61a7ef25dd30a197fe0086d0ff21ce4280 100644
--- a/components/history/core/browser/typed_url_data_type_controller.cc
+++ b/components/history/core/browser/typed_url_data_type_controller.cc
@@ -51,11 +51,11 @@ TypedUrlDataTypeController::TypedUrlDataTypeController(
const base::Closure& dump_stack,
syncer::SyncClient* sync_client,
const char* history_disabled_pref_name)
- : NonUIDataTypeController(syncer::TYPED_URLS,
- dump_stack,
- sync_client,
- syncer::GROUP_HISTORY,
- nullptr),
+ : AsyncDirectoryTypeController(syncer::TYPED_URLS,
+ dump_stack,
+ sync_client,
+ syncer::GROUP_HISTORY,
+ nullptr),
history_disabled_pref_name_(history_disabled_pref_name),
sync_client_(sync_client) {
pref_registrar_.Init(sync_client->GetPrefService());

Powered by Google App Engine
This is Rietveld 408576698