Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(664)

Unified Diff: components/payments/payment_request.mojom

Issue 2545523004: Rename canMakeActivePayment to canMakePayment (Closed)
Patch Set: Rebase Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/payments/payment_request.mojom
diff --git a/components/payments/payment_request.mojom b/components/payments/payment_request.mojom
index bc428667c2765c0a9eb7620387c3d84b43540edc..b6058f3c4e228d5897f71d29de8e6b02831a86c2 100644
--- a/components/payments/payment_request.mojom
+++ b/components/payments/payment_request.mojom
@@ -77,9 +77,9 @@ enum PaymentErrorReason {
NOT_SUPPORTED
};
-enum ActivePaymentQueryResult {
- CAN_MAKE_ACTIVE_PAYMENT,
- CANNOT_MAKE_ACTIVE_PAYMENT,
+enum CanMakePaymentQueryResult {
+ CAN_MAKE_PAYMENT,
+ CANNOT_MAKE_PAYMENT,
QUERY_QUOTA_EXCEEDED
};
@@ -90,7 +90,7 @@ interface PaymentRequestClient {
OnError(PaymentErrorReason error);
OnComplete();
OnAbort(bool aborted_successfully);
- OnCanMakeActivePayment(ActivePaymentQueryResult result);
+ OnCanMakePayment(CanMakePaymentQueryResult result);
};
struct PaymentItem {
@@ -196,5 +196,5 @@ interface PaymentRequest {
UpdateWith(PaymentDetails details);
Abort();
Complete(PaymentComplete result);
- CanMakeActivePayment();
+ CanMakePayment();
};

Powered by Google App Engine
This is Rietveld 408576698