Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(499)

Unified Diff: third_party/WebKit/Source/core/layout/ng/ng_physical_fragment.cc

Issue 2540653003: Implement collection of out-of-flow descendants (Closed)
Patch Set: CR fixes: rename Corner to StaticPosition Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/layout/ng/ng_physical_fragment.cc
diff --git a/third_party/WebKit/Source/core/layout/ng/ng_physical_fragment.cc b/third_party/WebKit/Source/core/layout/ng/ng_physical_fragment.cc
index 31f04b2f2c76f018c875871d69b21cdb950e355c..b6a1f67a32cc74edab79d517f371fc376015f870 100644
--- a/third_party/WebKit/Source/core/layout/ng/ng_physical_fragment.cc
+++ b/third_party/WebKit/Source/core/layout/ng/ng_physical_fragment.cc
@@ -14,13 +14,13 @@ NGPhysicalFragment::NGPhysicalFragment(
NGPhysicalSize overflow,
HeapVector<Member<const NGPhysicalFragmentBase>>& children,
HeapLinkedHashSet<WeakMember<NGBlockNode>>& out_of_flow_descendants,
- Vector<NGLogicalOffset> out_of_flow_offsets,
+ Vector<NGStaticPosition> out_of_flow_positions,
NGMarginStrut margin_strut)
: NGPhysicalFragmentBase(size, overflow, kFragmentBox),
margin_strut_(margin_strut) {
children_.swap(children);
out_of_flow_descendants_.swap(out_of_flow_descendants);
- out_of_flow_offsets_.swap(out_of_flow_offsets);
+ out_of_flow_positions_.swap(out_of_flow_positions);
}
DEFINE_TRACE_AFTER_DISPATCH(NGPhysicalFragment) {

Powered by Google App Engine
This is Rietveld 408576698