Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(10)

Unified Diff: third_party/WebKit/Source/modules/payments/PaymentRequestEvent.idl

Issue 2510833002: PaymentApp: Add interfaces for PaymentRequestEvent. (Closed)
Patch Set: Created 4 years, 1 month ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/payments/PaymentRequestEvent.idl
diff --git a/third_party/WebKit/Source/modules/payments/PaymentRequestEvent.idl b/third_party/WebKit/Source/modules/payments/PaymentRequestEvent.idl
new file mode 100644
index 0000000000000000000000000000000000000000..f19b2c62d87c30c19d3e62939465054cabd6ce1c
--- /dev/null
+++ b/third_party/WebKit/Source/modules/payments/PaymentRequestEvent.idl
@@ -0,0 +1,13 @@
+// Copyright 2016 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
+
+// https://w3c.github.io/webpayments-payment-apps-api/#idl-def-paymentrequestevent
+
+[
+ RuntimeEnabled=PaymentApp,
+ Exposed=ServiceWorker
+] interface PaymentRequestEvent : ExtendableEvent {
+ readonly attribute PaymentAppRequestData data;
+ void respondWith(Promise<PaymentResponse> r);
haraken 2016/11/21 00:15:55 Nit: I want to rename |r| to a more descriptive na
zino 2016/11/21 09:31:05 Done.
+};

Powered by Google App Engine
This is Rietveld 408576698