Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(12)

Side by Side Diff: chrome/test/data/android/payments/contact_details.js

Issue 2413833002: PaymentRequest: Rename ContactInfo to PayerInfo.
Patch Set: test Created 4 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 /*
2 * Copyright 2016 The Chromium Authors. All rights reserved.
3 * Use of this source code is governed by a BSD-style license that can be
4 * found in the LICENSE file.
5 */
6
7 /* global PaymentRequest:false */
8
9 /**
10 * Launches the PaymentRequest UI that requests contact details.
11 */
12 function buy() { // eslint-disable-line no-unused-vars
13 try {
14 new PaymentRequest(
15 [{supportedMethods: ['visa']}],
16 {total: {label: 'Total', amount: {currency: 'USD', value: '5.00'}}},
17 {requestPayerEmail: true, requestPayerPhone: true})
18 .show()
19 .then(function(resp) {
20 resp.complete('success')
21 .then(function() {
22 print(
23 resp.payerEmail + '<br>' + resp.payerPhone + '<br>' +
24 resp.methodName + '<br>' +
25 JSON.stringify(resp.details, undefined, 2));
26 })
27 .catch(function(error) {
28 print(error);
29 });
30 })
31 .catch(function(error) {
32 print(error);
33 });
34 } catch (error) {
35 print(error.message);
36 }
37 }
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698