Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(290)

Unified Diff: tools/gn/function_rebase_path_unittest.cc

Issue 2346913003: Make rebase_path("//foo", "//foo") resolve to "." (not "../foo") (Closed)
Patch Set: Created 4 years, 3 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « tools/gn/function_rebase_path.cc ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: tools/gn/function_rebase_path_unittest.cc
diff --git a/tools/gn/function_rebase_path_unittest.cc b/tools/gn/function_rebase_path_unittest.cc
index 4b09790fa7ebe18910872058ea9a555d0bde707c..d89b56f616b4252cf0eb0085403746c3c7961756 100644
--- a/tools/gn/function_rebase_path_unittest.cc
+++ b/tools/gn/function_rebase_path_unittest.cc
@@ -51,9 +51,7 @@ TEST(RebasePath, Strings) {
EXPECT_EQ("foo/", RebaseOne(scope, "//foo/", "//", "//"));
EXPECT_EQ("../../foo/bar", RebaseOne(scope, "//foo/bar", "//out/Debug", "."));
EXPECT_EQ("./", RebaseOne(scope, "//foo/", "//foo/", "//"));
- // Thie one is technically correct but could be simplified to "." if
- // necessary.
- EXPECT_EQ("../foo", RebaseOne(scope, "//foo", "//foo", "//"));
+ EXPECT_EQ(".", RebaseOne(scope, "//foo", "//foo", "//"));
// Test slash conversion.
EXPECT_EQ("foo/bar", RebaseOne(scope, "foo/bar", ".", "."));
« no previous file with comments | « tools/gn/function_rebase_path.cc ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698