Index: src/mips/macro-assembler-mips.h |
diff --git a/src/mips/macro-assembler-mips.h b/src/mips/macro-assembler-mips.h |
index 61a0c3a228fdc1d57c6c8e356942ce4800cefdba..741fe9c14fd112fbba1d832fe9fc3a4688305ad9 100644 |
--- a/src/mips/macro-assembler-mips.h |
+++ b/src/mips/macro-assembler-mips.h |
@@ -235,6 +235,14 @@ class MacroAssembler: public Assembler { |
mfc1(dst_high, FPURegister::from_code(src.code() + 1)); |
} |
+ inline void MoveHigh(Register dst_high, FPURegister src) { |
Paul Lind
2013/08/14 22:48:39
I think we should rename these FmoveHigh/FmoveLow,
palfia
2013/08/14 23:05:44
Done.
|
+ mfc1(dst_high, FPURegister::from_code(src.code() + 1)); |
+ } |
+ |
+ inline void MoveLow(Register dst_low, FPURegister src) { |
+ mfc1(dst_low, src); |
+ } |
+ |
inline void Move(FPURegister dst, Register src_low, Register src_high) { |
mtc1(src_low, dst); |
mtc1(src_high, FPURegister::from_code(dst.code() + 1)); |