Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(626)

Unified Diff: Source/core/page/Navigator.idl

Issue 22929011: Move productSub/vendor/vendorSub to Navigator class (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: Created 7 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « Source/core/page/Navigator.cpp ('k') | Source/core/page/NavigatorBase.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: Source/core/page/Navigator.idl
diff --git a/Source/core/page/Navigator.idl b/Source/core/page/Navigator.idl
index 6d23efd4bdf7e1aac92e98be80f7773c0ce20c4e..79f322d89f4804ae2c076cb5d5e6e72de0516659 100644
--- a/Source/core/page/Navigator.idl
+++ b/Source/core/page/Navigator.idl
@@ -23,13 +23,15 @@ interface Navigator {
readonly attribute PluginArray plugins;
readonly attribute MimeTypeArray mimeTypes;
readonly attribute DOMString product;
- readonly attribute DOMString productSub;
- readonly attribute DOMString vendor;
- readonly attribute DOMString vendorSub;
readonly attribute boolean cookieEnabled;
boolean javaEnabled();
void getStorageUpdates(); // FIXME: Remove this method or rename to yieldForStorageUpdates.
+
+ // Non-standard.
+ [MeasureAs=NavigatorProductSub] readonly attribute DOMString productSub;
+ [MeasureAs=NavigatorVendor] readonly attribute DOMString vendor;
+ [MeasureAs=NavigatorVendorSub] readonly attribute DOMString vendorSub;
};
Navigator implements NavigatorID;
« no previous file with comments | « Source/core/page/Navigator.cpp ('k') | Source/core/page/NavigatorBase.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698