Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(357)

Unified Diff: third_party/WebKit/Source/wtf/StdLibExtras.h

Issue 2257683002: Rename WTF::bitwise_cast to WTF::bitwiseCast. (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Created 4 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « third_party/WebKit/Source/wtf/HashFunctions.h ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: third_party/WebKit/Source/wtf/StdLibExtras.h
diff --git a/third_party/WebKit/Source/wtf/StdLibExtras.h b/third_party/WebKit/Source/wtf/StdLibExtras.h
index 0ec06def8ad666f1e87675db1ef7d38e9bbe8ac3..351507e25b34c737b171f74b77096974ba282780 100644
--- a/third_party/WebKit/Source/wtf/StdLibExtras.h
+++ b/third_party/WebKit/Source/wtf/StdLibExtras.h
@@ -170,9 +170,9 @@ namespace WTF {
* C++'s idea of a reinterpret_cast lacks sufficient cojones.
*/
template<typename TO, typename FROM>
-inline TO bitwise_cast(FROM from)
+inline TO bitwiseCast(FROM from)
{
- static_assert(sizeof(TO) == sizeof(FROM), "WTF::bitwise_cast sizeof casted types should be equal");
+ static_assert(sizeof(TO) == sizeof(FROM), "WTF::bitwiseCast sizeof casted types should be equal");
union {
FROM from;
TO to;
@@ -235,7 +235,7 @@ inline void* operator new(size_t, NotNullTag, void* location)
return location;
}
-using WTF::bitwise_cast;
+using WTF::bitwiseCast;
using WTF::safeCast;
#endif // WTF_StdLibExtras_h
« no previous file with comments | « third_party/WebKit/Source/wtf/HashFunctions.h ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698