Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(370)

Unified Diff: src/utils/SkCurveMeasure.h

Issue 2221203002: Move seg_to to a new header, define SkSegType enum there (Closed) Base URL: https://skia.googlesource.com/skia.git@master
Patch Set: Rename addSegmentToPath to SkPathMeasure_segTo Created 4 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/core/SkPathMeasurePriv.h ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/utils/SkCurveMeasure.h
diff --git a/src/utils/SkCurveMeasure.h b/src/utils/SkCurveMeasure.h
index 60de29e7a4643abd6aec587c41028b43ace57a27..b2d0ea17f3d4d2d2a8b600ebbe654968374cf91a 100644
--- a/src/utils/SkCurveMeasure.h
+++ b/src/utils/SkCurveMeasure.h
@@ -8,6 +8,7 @@
#ifndef SkCurveMeasure_DEFINED
#define SkCurveMeasure_DEFINED
+#include "SkPathMeasurePriv.h"
#include "SkPoint.h"
#include "SkNx.h"
@@ -26,14 +27,6 @@ static Sk8f weights = Sk8f::Load(weights8);
static Sk8f absc = 0.5f*(Sk8f::Load(absc8) + 1.0f);
-// this is the same enum as in SkPathMeasure but it doesn't have a name there
-enum SkSegType {
- kLine_SegType,
- kQuad_SegType,
- kCubic_SegType,
- kConic_SegType,
-};
-
class ArcLengthIntegrator {
public:
ArcLengthIntegrator() {}
« no previous file with comments | « src/core/SkPathMeasurePriv.h ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698