Chromium Code Reviews| Index: cc/layers/layer_impl.cc |
| diff --git a/cc/layers/layer_impl.cc b/cc/layers/layer_impl.cc |
| index 0e305b30b0cc28b7cddb4d610bcc7bef3be343f9..e99af4bfcce736ea9cd3cd34d030cf5507ab0d70 100644 |
| --- a/cc/layers/layer_impl.cc |
| +++ b/cc/layers/layer_impl.cc |
| @@ -701,6 +701,7 @@ void LayerImpl::ResetAllChangeTrackingForSubtree() { |
| layer_property_changed_ = false; |
| update_rect_ = gfx::RectF(); |
| + damage_rect_ = gfx::RectF(); |
| if (draw_properties_.render_surface) |
| draw_properties_.render_surface->ResetPropertyChangedFlag(); |
| @@ -1017,6 +1018,10 @@ void LayerImpl::SetUpdateRect(const gfx::RectF& update_rect) { |
| SetNeedsPushProperties(); |
| } |
| +void LayerImpl::AddLayerDamageRect(const gfx::RectF& damage_rect) { |
|
reveman
2014/04/17 05:18:34
should this be AddDamageRect or should SetUpdateRe
danakj
2014/04/17 14:14:34
SetUpdateRect should be renamed, so should update_
reveman
2014/04/18 14:30:56
Ok, I would then name this AddDamageRect right now
|
| + damage_rect_ = gfx::UnionRects(damage_rect_, damage_rect); |
| +} |
| + |
| void LayerImpl::SetContentBounds(const gfx::Size& content_bounds) { |
| if (this->content_bounds() == content_bounds) |
| return; |