Index: tests_lit/llvm2ice_tests/address-mode-opt.ll |
diff --git a/tests_lit/llvm2ice_tests/address-mode-opt.ll b/tests_lit/llvm2ice_tests/address-mode-opt.ll |
index ccd301c4e8789d780060af78194f09db5fe0fd21..901d1f00723b366312acd50cda10a7d0640a6330 100644 |
--- a/tests_lit/llvm2ice_tests/address-mode-opt.ll |
+++ b/tests_lit/llvm2ice_tests/address-mode-opt.ll |
@@ -187,3 +187,20 @@ entry: |
; CHECK: or |
; CHECK-NOT: movss xmm{{[0-9]+}},DWORD PTR [{{e..}}*4+0xFFFF] |
} |
+ |
+define internal void @invert_icmp(i32* %arg1, i32* %arg2) { |
+entry: |
+ %addr.other = load i32, i32* %arg2, align 1 |
+ br label %foo |
+foo: |
Jim Stichnoth
2016/07/08 11:45:46
I would name this something like "next" instead of
|
+ %addr.load = load i32, i32* %arg1, align 1 |
+ %cond = icmp slt i32 %addr.load, %addr.other |
+ br i1 %cond, label %if.then, label %if.else |
+if.then: |
+ ret void |
+if.else: |
+ ret void |
+; CHECK-LABEL: invert_icmp |
+; CHECK: cmp {{e..}},DWORD PTR [{{e..}}] |
+; CHECK: jle |
+} |