Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(601)

Side by Side Diff: third_party/WebKit/Source/modules/csspaint/Geometry.h

Issue 2080363002: Rename Geometry.h to PaintSize.h (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: reorder global-interface-listing-paint-worklet-expected.txt Created 4 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 // Copyright 2016 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 #ifndef Geometry_h
6 #define Geometry_h
7
8 namespace blink {
9
10 class Geometry : public GarbageCollectedFinalized<Geometry>, public ScriptWrappa ble {
11 WTF_MAKE_NONCOPYABLE(Geometry);
12 DEFINE_WRAPPERTYPEINFO();
13 public:
14 static Geometry* create(IntSize size)
15 {
16 return new Geometry(size);
17 }
18 virtual ~Geometry() {}
19
20 int width() const { return m_size.width(); }
21 int height() const { return m_size.height(); }
22
23 DEFINE_INLINE_TRACE() { }
24 private:
25 explicit Geometry(IntSize size) : m_size(size) { }
26
27 IntSize m_size;
28 };
29
30 } // namespace blink
31
32 #endif // Geometry_h
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698