Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(408)

Unified Diff: lib/src/command/list_package_dirs.dart

Issue 2044253003: Refactor Source and SourceRegistry. (Closed) Base URL: git@github.com:dart-lang/pub.git@master
Patch Set: Rename LiveSource to BoundSource. Created 4 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « lib/src/command/lish.dart ('k') | lib/src/command/uploader.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: lib/src/command/list_package_dirs.dart
diff --git a/lib/src/command/list_package_dirs.dart b/lib/src/command/list_package_dirs.dart
index 220d5b81cb16a4715c17e4106ebd3c00f2380880..b9d1b0110a095178ef13ae426b57ec9c5c949700 100644
--- a/lib/src/command/list_package_dirs.dart
+++ b/lib/src/command/list_package_dirs.dart
@@ -34,7 +34,7 @@ class ListPackageDirsCommand extends PubCommand {
// Include the local paths to all locked packages.
var packages = mapMap(entrypoint.lockFile.packages, value: (name, package) {
- var source = entrypoint.cache.sources[package.source];
+ var source = entrypoint.cache.source(package.source);
var packageDir = source.getDirectory(package);
// Normalize paths and make them absolute for backwards compatibility
// with the protocol used by the analyzer.
« no previous file with comments | « lib/src/command/lish.dart ('k') | lib/src/command/uploader.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698