Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(12)

Unified Diff: include/v8.h

Issue 2002203002: [api] Add more parameters to Object::GetPropertyNames (Closed) Base URL: https://chromium.googlesource.com/v8/v8.git@2016-05-06_keys_fast_path_1995263002
Patch Set: adding more tests Created 4 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | src/api.cc » ('j') | src/api.cc » ('J')
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: include/v8.h
diff --git a/include/v8.h b/include/v8.h
index b5db5fe4295d11d17589fdeb07fefdbf2cde7e81..5be21c6bb5b1ad33bb8212713b77b2a706a678b6 100644
--- a/include/v8.h
+++ b/include/v8.h
@@ -2631,6 +2631,10 @@ enum PropertyFilter {
SKIP_SYMBOLS = 16
};
+enum class KeyCollectionMode { OWN_ONLY, INCLUDE_PROTOS };
Igor Sheludko 2016/05/27 13:53:41 I think we use kBlaBlah naming convention for enum
+
+enum class IndexFilter { INCLUDE_INDICES, SKIP_INDICES };
+
/**
* Integrity level for objects.
*/
@@ -2780,6 +2784,9 @@ class V8_EXPORT Object : public Value {
V8_DEPRECATE_SOON("Use maybe version", Local<Array> GetPropertyNames());
V8_WARN_UNUSED_RESULT MaybeLocal<Array> GetPropertyNames(
Local<Context> context);
+ V8_WARN_UNUSED_RESULT MaybeLocal<Array> GetPropertyNames(
+ Local<Context> context, KeyCollectionMode mode,
+ PropertyFilter property_filter, IndexFilter index_filter);
/**
* This function has the same functionality as GetPropertyNames but
« no previous file with comments | « no previous file | src/api.cc » ('j') | src/api.cc » ('J')

Powered by Google App Engine
This is Rietveld 408576698