Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(142)

Unified Diff: tests/language/library1_negative_test.dart

Issue 19786006: - Change the test for ambiguous definitions to be a (Closed) Base URL: http://dart.googlecode.com/svn/branches/bleeding_edge/dart/
Patch Set: Created 7 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « tests/language/library1.dart ('k') | tests/language/library2.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: tests/language/library1_negative_test.dart
===================================================================
--- tests/language/library1_negative_test.dart (revision 25174)
+++ tests/language/library1_negative_test.dart (working copy)
@@ -1,16 +0,0 @@
-// Copyright (c) 2012, the Dart project authors. Please see the AUTHORS file
-// for details. All rights reserved. Use of this source code is governed by a
-// BSD-style license that can be found in the LICENSE file.
-
-// This test should fail to load because we are importing two libraries
-// which define the same top level name foo, and we are referring to the name.
-
-library Library1NegativeTest.dart;
-import "package:expect/expect.dart";
-import "library1.dart"; // Defines top level variable 'foo'
-import "library2.dart"; // Defines top level variable 'foo'
-
-
-main() {
- Expect.equals(0, foo); // Reference ambiguous name 'foo'
-}
« no previous file with comments | « tests/language/library1.dart ('k') | tests/language/library2.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698