Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(34)

Unified Diff: src/crankshaft/hydrogen.h

Issue 1925743002: [compiler] Rename OptimizingCompileJob to CompilationJob. (Closed) Base URL: https://chromium.googlesource.com/v8/v8.git@local_cleanup-compiler-simplify-29
Patch Set: Fix tests as well. Created 4 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/compiler/wasm-compiler.cc ('k') | src/optimizing-compile-dispatcher.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/crankshaft/hydrogen.h
diff --git a/src/crankshaft/hydrogen.h b/src/crankshaft/hydrogen.h
index 30655305f88c76b1ce60f6ff16bfd0fcf0f37e55..27f368f0f9547d506cb1e710a322151845421c46 100644
--- a/src/crankshaft/hydrogen.h
+++ b/src/crankshaft/hydrogen.h
@@ -30,12 +30,10 @@ class LAllocator;
class LChunk;
class LiveRange;
-class HCompilationJob final : public OptimizedCompileJob {
+class HCompilationJob final : public CompilationJob {
public:
explicit HCompilationJob(CompilationInfo* info)
- : OptimizedCompileJob(info, "Crankshaft"),
- graph_(nullptr),
- chunk_(nullptr) {}
+ : CompilationJob(info, "Crankshaft"), graph_(nullptr), chunk_(nullptr) {}
protected:
virtual Status CreateGraphImpl();
« no previous file with comments | « src/compiler/wasm-compiler.cc ('k') | src/optimizing-compile-dispatcher.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698