Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(46)

Unified Diff: src/builtins.cc

Issue 18749004: Rename AllocationSite::payload to AllocationSite::transition_info (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: Addressed comments Created 7 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/ast.cc ('k') | src/code-stubs-hydrogen.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/builtins.cc
diff --git a/src/builtins.cc b/src/builtins.cc
index d17137f2289f8a82326fef5953de930dbff9be94..f081e3d23b50f95b2ca46914d9e38b7c81d9ec3a 100644
--- a/src/builtins.cc
+++ b/src/builtins.cc
@@ -214,7 +214,7 @@ static MaybeObject* ArrayCodeGenericCommon(Arguments* args,
AllocationSiteInfo* info = AllocationSiteInfo::FindForJSObject(array);
if (info != NULL && info->IsValid()) {
AllocationSite* site = info->GetAllocationSite();
- ElementsKind to_kind = site->GetElementsKindPayload();
+ ElementsKind to_kind = site->GetElementsKind();
if (IsMoreGeneralElementsKindTransition(array->GetElementsKind(),
to_kind)) {
// We have advice that we should change the elements kind
« no previous file with comments | « src/ast.cc ('k') | src/code-stubs-hydrogen.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698