Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(30)

Unified Diff: CHANGELOG.md

Issue 1870543004: Add typed wrapper functions to delegate classes. (Closed) Base URL: git@github.com:dart-lang/async.git@master
Patch Set: Code review changes Created 4 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | lib/async.dart » ('j') | lib/src/delegate/event_sink.dart » ('J')
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 803b5899c01da1e6bb151ac4ea90dac199b94980..b18365fc540d2dafd57845db6a23d8cfc23d654e 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,14 +1,23 @@
-## 1.9.1
+## 1.10.0
-* Fix all strong mode warnings and add generic method annotations.
+* Add `DelegatingFuture.typed()`, `DelegatingStreamSubscription.typed()`,
+ `DelegatingStreamConsumer.typed()`, `DelegatingSink.typed()`,
+ `DelegatingEventSink.typed()`, and `DelegatingStreamSink.typed()` static
+ methods. These wrap untyped instances of these classes with the correct type
+ parameter, and assert the types of values as they're accessed.
+
+* Add a `DelegatingStream` class. This is behaviorally identical to `StreamView`
+ from `dart:async`, but it follows this package's naming conventions and
+ provides a `DelegatingStream.typed()` static method.
-* `new StreamQueue()` now takes a `Stream<T>` rather than a `Stream<dynamic>`.
- Passing a type that wasn't `is`-compatible with `Stream<T>` would already
- throw an error under some circumstances, so this is not considered a breaking
- change.
+* Fix all strong mode warnings and add generic method annotations.
-* `new SubscriptionStream()` now takes a `Stream<T>` rather than a
- `Stream<dynamic>`. Passing a type that wasn't `is`-compatible with `Stream<T>`
+* `new StreamQueue()`, `new SubscriptionStream()`, `new
+ DelegatingStreamSubscription()`, `new DelegatingStreamConsumer()`, `new
+ DelegatingSink()`, `new DelegatingEventSink()`, and `new
+ DelegatingStreamSink()` now take arguments with generic type arguments (for
+ example `Stream<T>`) rather than without (for example `Stream<dynamic>`).
+ Passing a type that wasn't `is`-compatible with the fully-specified generic
would already throw an error under some circumstances, so this is not
considered a breaking change.
« no previous file with comments | « no previous file | lib/async.dart » ('j') | lib/src/delegate/event_sink.dart » ('J')

Powered by Google App Engine
This is Rietveld 408576698