Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(122)

Unified Diff: third_party/WebKit/Source/web/WebFrame.cpp

Issue 1845543002: Rename Heap to ThreadHeap (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Created 4 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/web/WebFrame.cpp
diff --git a/third_party/WebKit/Source/web/WebFrame.cpp b/third_party/WebKit/Source/web/WebFrame.cpp
index a3c3b6bc5a5f5fbd6bde210088dba7968475b2ee..a65d50dcad1a89989d68feae3c674e1513e315df 100644
--- a/third_party/WebKit/Source/web/WebFrame.cpp
+++ b/third_party/WebKit/Source/web/WebFrame.cpp
@@ -313,9 +313,9 @@ ALWAYS_INLINE bool WebFrame::isFrameAlive(const WebFrame* frame)
return true;
if (frame->isWebLocalFrame())
- return Heap::isHeapObjectAlive(toWebLocalFrameImpl(frame));
+ return ThreadHeap::isHeapObjectAlive(toWebLocalFrameImpl(frame));
- return Heap::isHeapObjectAlive(toWebRemoteFrameImpl(frame));
+ return ThreadHeap::isHeapObjectAlive(toWebRemoteFrameImpl(frame));
}
template <typename VisitorDispatcher>
« no previous file with comments | « third_party/WebKit/Source/platform/testing/RunAllTests.cpp ('k') | third_party/WebKit/Source/web/WebHeap.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698