Index: src/objects.h |
diff --git a/src/objects.h b/src/objects.h |
index fcc6436e47748d636aba6eb46d20c679ffe8efb5..35ddaf7fc63d025937d9e26f6341c431749a607a 100644 |
--- a/src/objects.h |
+++ b/src/objects.h |
@@ -10698,6 +10698,9 @@ class ObjectVisitor BASE_EMBEDDED { |
// To allow lazy clearing of inline caches the visitor has |
// a rich interface for iterating over Code objects.. |
+ // Visits a code target in a constant pool entry. |
+ virtual void VisitCodeTarget(Address target_address_pointer); |
Michael Starzinger
2014/03/07 14:36:59
Can we rename this to method to make it explicit t
Michael Starzinger
2014/03/07 15:34:04
Actually, the more I think about it: Is there any
rmcilroy
2014/03/10 12:25:23
Yes you are right, this is much better - done.
|
+ |
// Visits a code target in the instruction stream. |
virtual void VisitCodeTarget(RelocInfo* rinfo); |
@@ -10739,6 +10742,9 @@ class ObjectVisitor BASE_EMBEDDED { |
// check for the presence of, a tag at this position in the stream. |
// Also used for marking up GC roots in heap snapshots. |
virtual void Synchronize(VisitorSynchronization::SyncTag tag) {} |
+ |
+ private: |
+ void VisitCodeTargetCommon(Address target_address); |
Michael Starzinger
2014/03/07 14:36:59
See comment in the .cc file.
rmcilroy
2014/03/10 12:25:23
Removed VisitCodeTarget(Address) as discussed, so
|
}; |