Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(363)

Side by Side Diff: LayoutTests/fast/canvas/script-tests/canvas-path-object.js

Issue 178673002: Rename Path to Path2D (Closed) Base URL: https://chromium.googlesource.com/chromium/blink.git@path
Patch Set: Merge to head which includes isPoint and addPath changes. Created 6 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
1 description("Ensure that the constructor for Path object and dependent functions exist."); 1 description("Ensure that the constructor for Path object and dependent functions exist.");
2 2
3 shouldBe("typeof document.getElementById", '"function"'); 3 shouldBe("typeof document.getElementById", '"function"');
4 4
5 var path = new Path(); 5 var path = new Path2D();
6 shouldBeType("path", "Path"); 6 shouldBeType("path", "Path2D");
7 shouldBe("typeof path.closePath", '"function"'); 7 shouldBe("typeof path.closePath", '"function"');
8 shouldBe("typeof path.moveTo", '"function"'); 8 shouldBe("typeof path.moveTo", '"function"');
9 shouldBe("typeof path.lineTo", '"function"'); 9 shouldBe("typeof path.lineTo", '"function"');
10 shouldBe("typeof path.quadraticCurveTo", '"function"'); 10 shouldBe("typeof path.quadraticCurveTo", '"function"');
11 shouldBe("typeof path.bezierCurveTo", '"function"'); 11 shouldBe("typeof path.bezierCurveTo", '"function"');
12 shouldBe("typeof path.arcTo", '"function"'); 12 shouldBe("typeof path.arcTo", '"function"');
13 shouldBe("typeof path.arc", '"function"'); 13 shouldBe("typeof path.arc", '"function"');
14 shouldBe("typeof path.rect", '"function"'); 14 shouldBe("typeof path.rect", '"function"');
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698