Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(308)

Unified Diff: device/devices_app/devices_app.cc

Issue 1681813002: Rename Connection::AddService/ConnectToService to Connection::AddInterface/GetInterface (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@interface_binder
Patch Set: . Created 4 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: device/devices_app/devices_app.cc
diff --git a/device/devices_app/devices_app.cc b/device/devices_app/devices_app.cc
index a34064404fa3040b6cfc6a5367b3f25add213a56..8bb9ab9387203ed0ce0837115f906588ba34b8a2 100644
--- a/device/devices_app/devices_app.cc
+++ b/device/devices_app/devices_app.cc
@@ -89,7 +89,7 @@ void DevicesApp::Initialize(mojo::Shell* shell,
}
bool DevicesApp::AcceptConnection(mojo::Connection* connection) {
- connection->AddService<usb::DeviceManager>(this);
+ connection->AddInterface<usb::DeviceManager>(this);
return true;
}
@@ -103,7 +103,7 @@ void DevicesApp::Create(mojo::Connection* connection,
// Bind the new device manager to the connecting application's permission
// provider.
usb::PermissionProviderPtr permission_provider;
- connection->ConnectToService(&permission_provider);
+ connection->GetInterface(&permission_provider);
// Owned by its message pipe.
usb::DeviceManagerImpl* device_manager = new usb::DeviceManagerImpl(

Powered by Google App Engine
This is Rietveld 408576698