Index: content/child/content_child_helpers.cc |
diff --git a/content/child/content_child_helpers.cc b/content/child/content_child_helpers.cc |
index 4398bc067ae694eb5815a446f2dacbe1b873696c..66775a2d5696159b9a0d0ebd72f8bea8da21adf1 100644 |
--- a/content/child/content_child_helpers.cc |
+++ b/content/child/content_child_helpers.cc |
@@ -18,6 +18,12 @@ |
namespace content { |
+// TODO(primiano): get rid of this file together with --memory-metrics. |
+// This function is both misplaced and misnamed. If useful, this should |
+// be moved to base/process/process_metrics.h. Regardless the name, |
+// though, this provides only a partial and misleading value. |
+// Unfortunately some telemetry benchmark rely on it and these need to |
+// be refactored before getting rid of this. See crbug.com/581365 . |
#if defined(OS_LINUX) || defined(OS_ANDROID) |
size_t GetMemoryUsageKB() { |
struct mallinfo minfo = mallinfo(); |