Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2718)

Unified Diff: chrome/browser/google_apis/gdata_wapi_service.h

Issue 16175003: google_apis: Rename OperationRunner to RequestSender (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src
Patch Set: rebase Created 7 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: chrome/browser/google_apis/gdata_wapi_service.h
diff --git a/chrome/browser/google_apis/gdata_wapi_service.h b/chrome/browser/google_apis/gdata_wapi_service.h
index 6c4f54e089ebdbf693f1c5440fc353e6ed87d515..7d64e9f059900a47a261fe6895a12c042726bb4a 100644
--- a/chrome/browser/google_apis/gdata_wapi_service.h
+++ b/chrome/browser/google_apis/gdata_wapi_service.h
@@ -28,7 +28,7 @@ class URLRequestContextGetter;
namespace google_apis {
class AuthService;
-class OperationRunner;
+class RequestSender;
// This class provides documents feed service calls for WAPI (codename for
// DocumentsList API).
@@ -165,7 +165,7 @@ class GDataWapiService : public DriveServiceInterface,
virtual void OnOAuth2RefreshTokenChanged() OVERRIDE;
net::URLRequestContextGetter* url_request_context_getter_; // Not owned.
- scoped_ptr<OperationRunner> runner_;
+ scoped_ptr<RequestSender> sender_;
ObserverList<DriveServiceObserver> observers_;
// Operation objects should hold a copy of this, rather than a const
// reference, as they may outlive this object.
« no previous file with comments | « chrome/browser/google_apis/gdata_wapi_operations_unittest.cc ('k') | chrome/browser/google_apis/gdata_wapi_service.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698