Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(4666)

Unified Diff: chrome/browser/google_apis/drive_api_service.h

Issue 16175003: google_apis: Rename OperationRunner to RequestSender (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src
Patch Set: rebase Created 7 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: chrome/browser/google_apis/drive_api_service.h
diff --git a/chrome/browser/google_apis/drive_api_service.h b/chrome/browser/google_apis/drive_api_service.h
index 2541c6c1f2fd6b3f307d4905acbb9e1642ac3402..75be1ae402681f7aa35dfe6bc03409b782f32eb9 100644
--- a/chrome/browser/google_apis/drive_api_service.h
+++ b/chrome/browser/google_apis/drive_api_service.h
@@ -25,7 +25,7 @@ class URLRequestContextGetter;
} // namespace net
namespace google_apis {
-class OperationRunner;
+class RequestSender;
// This class provides Drive operation calls using Drive V2 API.
// Details of API call are abstracted in each operation class and this class
@@ -162,7 +162,7 @@ class DriveAPIService : public DriveServiceInterface,
net::URLRequestContextGetter* url_request_context_getter_;
Profile* profile_;
- scoped_ptr<OperationRunner> runner_;
+ scoped_ptr<RequestSender> sender_;
ObserverList<DriveServiceObserver> observers_;
DriveApiUrlGenerator url_generator_;
const std::string custom_user_agent_;
« no previous file with comments | « chrome/browser/google_apis/drive_api_operations_unittest.cc ('k') | chrome/browser/google_apis/drive_api_service.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698