Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(263)

Unified Diff: dart/sdk/lib/_internal/compiler/implementation/js_backend/namer.dart

Issue 16135004: Rename JS_CURRENT_ISOLATE to JS_CURRENT_ISOLATE_CONTEXT. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge
Patch Set: Created 7 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: dart/sdk/lib/_internal/compiler/implementation/js_backend/namer.dart
diff --git a/dart/sdk/lib/_internal/compiler/implementation/js_backend/namer.dart b/dart/sdk/lib/_internal/compiler/implementation/js_backend/namer.dart
index 3f43bc63952499d278232cad93ffc3a5c3fa0bfa..c83e71490656819a95133d6925a4f6424253a096 100644
--- a/dart/sdk/lib/_internal/compiler/implementation/js_backend/namer.dart
+++ b/dart/sdk/lib/_internal/compiler/implementation/js_backend/namer.dart
@@ -172,7 +172,7 @@ class Namer implements ClosureNamer {
return _jsVariableReserved;
}
- final String CURRENT_ISOLATE = r'$';
+ final String CURRENT_ISOLATE;
final String getterPrefix = r'get$';
final String setterPrefix = r'set$';
@@ -204,6 +204,7 @@ class Namer implements ClosureNamer {
Namer(Compiler compiler)
: compiler = compiler,
+ CURRENT_ISOLATE = compiler.globalJsName,
globals = new Map<Element, String>(),
shortPrivateNameOwners = new Map<String, LibraryElement>(),
bailoutNames = new Map<Element, String>(),

Powered by Google App Engine
This is Rietveld 408576698