Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1554)

Unified Diff: dart/sdk/lib/_internal/compiler/implementation/apiimpl.dart

Issue 16135004: Rename JS_CURRENT_ISOLATE to JS_CURRENT_ISOLATE_CONTEXT. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge
Patch Set: Created 7 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: dart/sdk/lib/_internal/compiler/implementation/apiimpl.dart
diff --git a/dart/sdk/lib/_internal/compiler/implementation/apiimpl.dart b/dart/sdk/lib/_internal/compiler/implementation/apiimpl.dart
index c582bc082ed6da39d177206fc20eea9ead98e5a2..067417ae84a281c6ac181d1d0cf66b66fb3ec545 100644
--- a/dart/sdk/lib/_internal/compiler/implementation/apiimpl.dart
+++ b/dart/sdk/lib/_internal/compiler/implementation/apiimpl.dart
@@ -59,6 +59,8 @@ class Compiler extends leg.Compiler {
preserveComments: hasOption(options, '--preserve-comments'),
verbose: hasOption(options, '--verbose'),
sourceMapUri: extractSourceMapUri(options),
+ globalJsName: extractStringOption(
+ options, '--global-js-name=', r'$'),
buildId: extractStringOption(
options, '--build-id=',
"build number could not be determined")) {

Powered by Google App Engine
This is Rietveld 408576698