Index: src/type-cache.h |
diff --git a/src/type-cache.h b/src/type-cache.h |
index 2b04c247cb8864a5a9ee777dc4a48ef70e6a813c..f55198f8899be87c322621820c3fa72e3d900361 100644 |
--- a/src/type-cache.h |
+++ b/src/type-cache.h |
@@ -46,7 +46,11 @@ class TypeCache final { |
Type* const kZeroish = |
Type::Union(kSingletonZero, Type::MinusZeroOrNaN(), zone()); |
Type* const kInteger = CreateRange(-V8_INFINITY, V8_INFINITY); |
- Type* const kWeakint = Type::Union(kInteger, Type::MinusZeroOrNaN(), zone()); |
+ Type* const kPositiveInteger = CreateRange(0.0, V8_INFINITY); |
+ Type* const kIntegerish = Type::Union(kInteger, Type::MinusZero(), zone()); |
Jarin
2015/11/05 09:25:29
I think we need better names for this. How about k
Benedikt Meurer
2015/11/05 09:30:05
Done.
|
+ Type* const kWeakint = Type::Union(kIntegerish, Type::NaN(), zone()); |
+ |
+ Type* const kPositiveSafeInteger = CreateRange(0.0, kMaxSafeInteger); |
Type* const kIntegral32 = Type::Union(kInt32, kUint32, zone()); |