Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(186)

Issue 1427433017: Add a "guard" content settings type for chooser permissions.

Created:
5 years, 1 month ago by Reilly Grant (use Gerrit)
Modified:
5 years ago
CC:
chromium-reviews, kcarattini+watch_chromium.org, markusheintz_, msramek+watch_chromium.org, raymes+watch_chromium.org
Base URL:
https://chromium.googlesource.com/chromium/src.git@permission_store
Target Ref:
refs/pending/heads/master
Project:
chromium
Visibility:
Public.

Description

Add a "guard" content settings type for chooser permissions. This content setting should default to allow, but can be set to deny by group policy in order to disable a feature that normally grants permissions by prompting the user with a chooser. The new CanRequestObjectPermission() function should be called by the chooser UI before showing the user anything and cause the request to fail if permission is denied. BUG=529950

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+34 lines, -1 line) Patch
M chrome/browser/permissions/chooser_context_base.h View 2 chunks +9 lines, -0 lines 0 comments Download
M chrome/browser/permissions/chooser_context_base.cc View 2 chunks +18 lines, -1 line 0 comments Download
M chrome/browser/usb/usb_chooser_context.cc View 1 chunk +1 line, -0 lines 0 comments Download
M components/content_settings/core/browser/content_settings_registry.cc View 1 chunk +4 lines, -0 lines 0 comments Download
M components/content_settings/core/common/content_settings.cc View 1 chunk +1 line, -0 lines 0 comments Download
M components/content_settings/core/common/content_settings_types.h View 1 chunk +1 line, -0 lines 0 comments Download

Depends on Patchset:

Messages

Total messages: 5 (1 generated)
Reilly Grant (use Gerrit)
mlamouri@chromium.org: Please review changes in chrome/browser/permissions. raymes@chromium.org: Please review changes in components/content_settings.
5 years, 1 month ago (2015-11-11 00:36:27 UTC) #2
raymes
The code lg but I'm wondering now if we should hold off on adding this ...
5 years, 1 month ago (2015-11-11 02:38:26 UTC) #3
mlamouri (slow - plz ping)
IIRC, you suggested adding this Raymes. I told Reilly to move this to split this ...
5 years, 1 month ago (2015-11-23 17:53:22 UTC) #4
raymes
5 years ago (2015-11-23 23:50:01 UTC) #5
On 2015/11/23 17:53:22, Mounir Lamouri wrote:
> IIRC, you suggested adding this Raymes. I told Reilly to move this to split
this
> to a different CL to make things easier. If you think this feature is no
longer
> needed, maybe we should put this aside?

Agreed - Reilly and I chatted and decided to hold off on this for the time
being.

Powered by Google App Engine
This is Rietveld 408576698