Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(296)

Unified Diff: utils/pub/utils.dart

Issue 14251013: Rename unsubscribeOnError to cancelOnError. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« sdk/lib/async/stream.dart ('K') | « utils/pub/safe_http_server.dart ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: utils/pub/utils.dart
diff --git a/utils/pub/utils.dart b/utils/pub/utils.dart
index 47c27fc89b49f67a7cf5276d24a3dc3389cc388a..85411740ea88091e772444df540cb13fb09644a7 100644
--- a/utils/pub/utils.dart
+++ b/utils/pub/utils.dart
@@ -172,7 +172,7 @@ Future streamFirst(Stream stream) {
completer.completeError(e.error, e.stackTrace);
}, onDone: () {
completer.completeError(new StateError("No elements"));
- }, unsubscribeOnError: true);
+ }, cancelOnError: true);
return completer.future;
}
« sdk/lib/async/stream.dart ('K') | « utils/pub/safe_http_server.dart ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698