Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(622)

Unified Diff: tests/lib/async/stream_state_helper.dart

Issue 14251013: Rename unsubscribeOnError to cancelOnError. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: tests/lib/async/stream_state_helper.dart
diff --git a/tests/lib/async/stream_state_helper.dart b/tests/lib/async/stream_state_helper.dart
index b982d9d23be4e82fd13fec277e913907f31fbeac..ac6d94922cb864995f27da4c7f83b2f040da4877 100644
--- a/tests/lib/async/stream_state_helper.dart
+++ b/tests/lib/async/stream_state_helper.dart
@@ -36,15 +36,15 @@ class StreamProtocolTest {
void error(var error) { _controller.addError(error); }
void close() { _controller.close(); }
- void subscribe({bool unsubscribeOnError : false}) {
+ void subscribe({bool cancelOnError : false}) {
// TODO(lrn): Handle more subscriptions (e.g., a subscription-id
// per subscription, and an id on event _expectations).
if (_subscription != null) throw new StateError("Already subscribed");
_subscription = _controller.stream.listen(_onData,
onError: _onError,
onDone: _onDone,
- unsubscribeOnError:
- unsubscribeOnError);
+ cancelOnError:
+ cancelOnError);
}
void pause([Future resumeSignal]) {

Powered by Google App Engine
This is Rietveld 408576698